[torqueusers] Torque on HPUX (any flavor) - pbs_iff authentication

Lippert, Kenneth B. Kenneth.Lippert at alcoa.com
Thu Dec 8 08:15:42 MST 2005


 Sorry to be a pain, but I think the possibilities are narrowing here.
I still don't have a working system but I have new info.

First of all, for a brief time yesterday everything WORKED!  The

"pbs_iff -t server 15001" was fine,

"pbsnodes" issued on the HPUX client worked!

"qstat -n" issued on the HPUX client worked, whether as root or someone
else.

Then it stopped working and went back to the way it was.   The pbs_iff
worked but the other two command failed with:

"pbs_iff: Invalid credential MSG=cannot authenticate user.
 No permission.
 /usr/local/bin/pbsnodes: cannot connect to server server.atc.alcoa.com,
error 15007"

I later discovered that our main DNS lost a disk and was down.
Apparently when pbs was working was when the backup DNS was being used.
I did a "dig" on both DNS's and compared the results, other than the
ORDER of some entries in the "AUTHORITY SECTION" they were identical in
content.

Today as I continue to dig I discovered one more thing.  If I set the
"acl_host_enable" to FALSE on the server, then I am back to my original
condition: (the pbs_iff -t is ok, but other commands fail).  If I set
the acl_host_enable TRUE, then even the pbs_iff fails with:

"pbs_iff: Access from host not allowed, or unknown host"

even though I have acl_hosts = *.*.alcoa.com.

I am still trying to get a hold of my network admins to see what they
think about the DNS issue, but if anyone here as any new insights, I
would greatly appreciate them.

Thank you,
-k


More information about the torqueusers mailing list