garrick at usc.edu
Wed Dec 7 14:05:50 MST 2005
On Wed, Dec 07, 2005 at 03:53:59PM +0100, Simon Robbins alleged:
> Hi Garrick,
> I don't like the environment variable name "TMPDIR"
> used in torque 2. I attach the patches that I think
> are needed to change the name of this to PBS_TMPDIR,
> this seems to work on AMD Opterons.
> Until torque2 I was using an old patch and changing
> the name of this variable to PBS_TMPDIR.
> Unfortunately I have just had a user who was until
> now been innocently using $TMPDIR; torque deleted
> the contents of this directory when the job finished :-(
> What do people think about re-naming this variable?
So the user is supplying their own TMPDIR variable to the job, set to a
directory that doesn't exist, TORQUE created the directory, and the user
was surprised when TORQUE deleted it after the job?
Garrick Staples, Linux/HPCC Administrator
University of Southern California
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20051207/e356855f/attachment.bin
More information about the torqueusers