troy at osc.edu
Wed Dec 7 08:16:14 MST 2005
On Wed, 2005-12-07 at 15:53 +0100, Simon Robbins wrote:
> I don't like the environment variable name "TMPDIR"
> used in torque 2. I attach the patches that I think
> are needed to change the name of this to PBS_TMPDIR,
> this seems to work on AMD Opterons.
> Until torque2 I was using an old patch and changing
> the name of this variable to PBS_TMPDIR.
> Unfortunately I have just had a user who was until
> now been innocently using $TMPDIR; torque deleted
> the contents of this directory when the job finished :-(
> What do people think about re-naming this variable?
I would object most strenuously to renaming it, as my user community
has about 15 years' worth of job scripts using $TMPDIR on various batch
systems (NQS, Cray NQE, OpenPBS, PBS Pro, and TORQUE) and I'd prefer not
to have to retrain them all.
Troy Baer troy at osc.edu
Science & Technology Support http://www.osc.edu/hpc/
Ohio Supercomputer Center 614-292-9701
More information about the torqueusers