[torqueusers] Problems in Installing Torque

Garrick Staples garrick at usc.edu
Wed Aug 24 20:09:07 MDT 2005


On Fri, Aug 19, 2005 at 01:48:15AM +0100, Kashif Saleem alleged:
> Hi All,
>        I downloaded the TORQUE torque-1.2.0p5 and installed as shown in fig:
> acconfig.h  CHANGELOG     config.status  contrib      doc       Makefile.in      README.torque  torque.setup
> aclocal.m4  config.cache  configure      CVS          INSTALL   PBS_License.txt  Release_Notes
> buildutils  config.log    configure.in   DEVELOPMENT  Makefile  README.mpiexec   src
> 
> I configured the serve by executing the command  
> ./torque.setup root
> 
> I verified my server configuration as shown below:
> [root at labpc-18 torque-1.2.0p5]# qstat -q
>  
> server: labpc-18.nesc.gla.ac.uk
>  
> Queue            Memory CPU Time Walltime Node Run Que Lm  State
> ---------------- ------ -------- -------- ---- --- --- --  -----
> batch              --      --       --     --    0   0 --   E R
>                                                --- ---
>                                                  0   0
> 
> I need couple of question to ask  as follows:
> 
> 1) whether the above output specifying that I have installed the
> server correctly.

It doesn't mean that everything is right, but it's certainly a start :)

Have you seen http://www.clusterresources.com/products/torque/docs20/ ?


> 2)In my server installation there is no directory "server_priv", so I
> am wondering whether I have to make this directory myself and then
> create nodes file where I specify all list of nodes.

The server_priv directory should be in /usr/spool/PBS


> 3)Inorder to install TORQUE on the slave nodes:what i did I  copied
> this server installation to slave machine and run make install in the
> src/mom_priv directory,but again there is no mom_priv directory there
> so I am wondering whether I have to create myself and then I should
> create config with server entry along with $clienthost.

There should be a src/resmom directory, and after the install you should
see a /var/spool/PBS/mom_priv directory.


> 4)the other thing I am confused about the $clienthost what is the
> value of this variable,is it clienthost IP or what?

It is the hostname of your server.

-- 
Garrick Staples, Linux/HPCC Administrator
University of Southern California
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20050824/4588101d/attachment.bin


More information about the torqueusers mailing list