[torqueusers] Bug in chk_file_sec: Relative Symlinks

jacksond at supercluster.org jacksond at supercluster.org
Thu Sep 23 09:47:41 MDT 2004


Eric,

   Thanks for the report and the patch!  It will be available in the next 
snapshot.

Dave

On Wed, 22 Sep 2004, Eric J. Bowersox wrote:

> I've discovered a bug in the way that Torque's library routine
> chk_file_sec handles relative symlinks.  This manifested itself in a
> rather striking fashion on my workstation, where my "/var" is actually a
> symlink to "x/var" (/x being a separate filesystem).
>
> When pbs_server starts up, it attempts to run chk_file_sec on
> /var/spool/PBS/server_priv/jobs (since /var/spool/PBS was defined as the
> home directory for the server).  As the function worked its way up the
> directory path, it eventually got to /var, and read it as a symlink.
> Unfortunately, it created the full pathname, not as "/x/var", but as
> "/var/x/var".  It then tried to check this path, working its way up to
> /var, where it read the symlink, and assembled the name "/var/x/var",
> and...you get the idea.  Eventually, of course, it segfaulted.
>
> The attached patch eliminates that problem, and gets pbs_server running
> properly for me.  (Apologies for the attachment, but my mail client was
> wrapping lines when I tried to include the file directly as text...)
>
>


More information about the torqueusers mailing list