[torqueusers] Torque/Maui problem with which nodes are job-exclusive/free

Garrick Staples garrick at usc.edu
Tue Oct 19 09:57:57 MDT 2004


On Tue, Oct 19, 2004 at 04:41:19PM +0200, Bas van der Vlies alleged:
> We at SARA are installing a new cluster that has 272 dual processor 
> nodes.  We are using torque-1.1.0p2 and maui 3.2.6.p9.
> 
> We have configured torque/maui so that there is only one job per node.
> An user can decide if he want to use one or two processors on an node, eg:
>   1) qsub -I -lnodes=4 (4 nodes)
>   2) qsub -I -lnodes=4:ppn=2 (4 nodes, 2 processors of each node)

This is exactly like my cluster.

 
> This works as expected. Now the problem is, if we use pbsnodes -a 
> displays in example 1 all the nodes as 'free' and in example 2 it will 
> display the nodes as 'job-exclusive'.
> 
> We would expect it will display 'job-exclusive' for both examples. It 
> this an bug?

That is how it has always worked for me.  The single tasked nodes will be
"free" until the load average is over the highwater mark in the pbs_mom
config, in which case, it will then be "busy".

-- 
Garrick Staples, Linux/HPCC Administrator
University of Southern California
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20041019/f19d5927/attachment.bin


More information about the torqueusers mailing list