[torqueusers] ANNOUNCE: New version to build a debian package for torque

Bas van der Vlies basv at sara.nl
Fri Oct 8 08:01:42 MDT 2004


0.8.7
   - Supported the new release 1.1.0p2

   - disabled build of gui cmds

   - Added an patch for postinst that does an better check if the gui are
     really installed. If yes rebuild the indexes.
     Contributed by: Josh Lauricha

   - ptmx patch in the 2.6 kernel the handeling of pty's is
     different. The patche is automatically applied if you compile the
     package on a 2.6 platform


You can download the software from:
     ftp://ftp.sara.nl/pub/outgoing/torque_2_deb.tar.gz

How to use it:
   -  Unpack it in torque source directory, eg:
      cd torque-1.1.0p2
      tar xvzf torque_2_deb.tar.gz
      mv  torque_2_deb-<version> debian
      debian/rules binary


It is build with the following options (see debian/rules):
         ./configure --prefix=/usr \
           --libdir=/usr/lib/torque \
           --includedir=/usr/include/torque \
           --set-server-home=/var/spool/torque \
           --set-tmpdir=/var/tmp \
           --enable-syslog \
           --set-sched=c \
           --set-sched-code=fifo \
           --set-default-server=localhost \
	  --disable-gui \
           --with-scp

In this package there is also an init.d script. This script looks at
/etc/default/torque to see which daemons must be started.
-- 
--
********************************************************************
*                                                                  *
*  Bas van der Vlies                     e-mail: basv at sara.nl      *
*  SARA - Academic Computing Services    phone:  +31 20 592 8012   *
*  Kruislaan 415                         fax:    +31 20 6683167    *
*  1098 SJ Amsterdam                                               *
*                                                                  *
********************************************************************


More information about the torqueusers mailing list