[torqueusers] Where is xpbsmon?

Garrick Staples garrick at usc.edu
Sun Dec 19 02:16:15 MST 2004


On Sun, Dec 19, 2004 at 09:49:53AM +0100, Robert Tafner alleged:
> Garrick Staples wrote:
> >On Sat, Dec 18, 2004 at 09:06:23PM +0100, Robert Tafner alleged:
> >
> >>Hi,
> >>
> >>I tried to compile torque with the options --with-tcl and --enable-gui. 
> >>The compilation and make finished successful but I can't find xpbsmon 
> >>anywhere... I tried it too with option --with-tclx but that always gives 
> >>me an error message? How do I get support for X?
> >
> >
> >What's the error message?  That's probably what is preventing xpbsmon from
> >being built.

> gcc -Wall -g -O2 -I../../src/include -I../../src/include -I/usr/include 
> -I/usr/include/tcl8.3 -DHAVE_CONFIG_H -o pbs_tclsh pbs_tclWrap.o 
> site_tclWrap.o pbsTclInit.o  ../lib/Liblog/liblog.a 
> ../lib/Libcmds/libcmds.a ../lib/Libnet/libnet.a ../lib/Libpbs/libpbs.a 
> -L/usr/lib -ltclx -ltkx -ltcl8.3 -lm -ldl
> /usr/bin/ld: cannot find -ltclx

That's the problem, there is no libtclx.so on your system.  I don't know what
linux distro you are using, but find the package that has libtclx.so, install
it, and run 'make' again.

Some distros will have libtclx8.3.so instead, and a quick symlink will fix your
problem.  cd to the directory with libtclx8.3.so (probably /usr/lib/) and do
'ln -s libtclx8.3.so libtclx.so'.

Hope that helps.

-- 
Garrick Staples, Linux/HPCC Administrator
University of Southern California
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20041219/2ff55a47/attachment.bin


More information about the torqueusers mailing list