[torquedev] [Bug 196] tcp.h not installed

bugzilla-daemon at supercluster.org bugzilla-daemon at supercluster.org
Tue May 22 18:22:11 MDT 2012


http://www.clusterresources.com/bugzilla/show_bug.cgi?id=196

--- Comment #3 from Martin Siegert <siegert at sfu.ca> 2012-05-22 18:22:10 MDT ---
I applied the patch and ran ./autogen.sh, but configure fails instantly with

configure: error: cannot find macro directory `m4'

Apparently this is due to the version of libtoolize on SL-5.6 (libtool-1.5.22).
Thus, I ran autogen.sh on opensuse-12.1. This generated the following warning
from aclocal (the same also from autoconf -f and autoheader -f):

configure.ac:674: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in
body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2591: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
acinclude.m4:156: TAC_SYS_LARGEFILE is expanded from...
configure.ac:674: the top level

and then a lot of errors from automake -a -c -f about missing test directories
(from, e.g., src/lib/Libattr/Makefile.am, line 4) and configure.ac, line 114:
configure.ac:114: required file `src/cmds/test/Makefile.in' not found
etc.

After that the file src/include/Makefile.in remained unchanged, i.e.,
include_HEADERS still does not contain tcp.h whereas noinst_HEADERS still
does.

-- 
Configure bugmail: http://www.clusterresources.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the torquedev mailing list