[torquedev] [Bug 210] New: Cannot configure 4.1-fixes on Ubuntu

bugzilla-daemon at supercluster.org bugzilla-daemon at supercluster.org
Tue Jul 31 00:41:27 MDT 2012


http://www.clusterresources.com/bugzilla/show_bug.cgi?id=210

           Summary: Cannot configure 4.1-fixes on Ubuntu
           Product: TORQUE
           Version: 4.0.*
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: enhancement
          Priority: P5
         Component: libtorque
        AssignedTo: dbeer at adaptivecomputing.com
        ReportedBy: chris at csamuel.org
                CC: torquedev at supercluster.org
   Estimated Hours: 0.0


When you try and configure 4.1-fixes on Ubuntu 12.04 it fails, saying:

checking for xmlGetProp in -l/usr/lib/x86_64-linux-gnu -lxml2... no
configure: error: TORQUE needs libxml2-devel in order to build

But the error in the logs is:

configure:14048: checking for xmlGetProp in -l/usr/lib/x86_64-linux-gnu -lxml2
configure:14073: gcc -o conftest -g -O2 -D_LARGEFILE64_SOURCE   conftest.c
-l/usr/lib/x86_64-linux-gnu -lxml2 
 -lcrypto -lssl   -lpthread -lrt >&5
/usr/bin/ld: cannot find -l/usr/lib/x86_64-linux-gnu

Not sure where that came from..

The libxml2-dev package is installed:

samuel at eris:/tmp/4.1-fixes$ apt-cache policy libxml2-dev
libxml2-dev:
  Installed: 2.7.8.dfsg-5.1ubuntu4.1
  Candidate: 2.7.8.dfsg-5.1ubuntu4.1

-- 
Configure bugmail: http://www.clusterresources.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the torquedev mailing list