[torquedev] torque-4.1.0: qstat <queue> hangs

Martin Siegert siegert at sfu.ca
Mon Jul 9 18:07:06 MDT 2012


On Mon, Jul 09, 2012 at 01:59:40PM -0600, Ken Nielson wrote:
> 
>    On Mon, Jul 9, 2012 at 10:23 AM, David Beer
>    <[1]dbeer at adaptivecomputing.com> wrote:
> 
>      Martin,
>      I haven't been able to reproduce this issue. Just to clarify - what
>      kind of queue is it and what state is it in?
>      Also, when you say hangs, do you mean it is slow to respond or do
>      you mean it never responds?
>      David
> 
>    On Fri, Jul 6, 2012 at 8:51 PM, Martin Siegert <[2]siegert at sfu.ca>
>    wrote:
> 
>      Hi,
>      I just installed torque-4.1.0 and have problems with the qstat
>      command:
>      qstat queuename
>      hangs (whereas just "qstat" works).
>      Cheers,
>      Martin
>      --
>      Martin Siegert
>      Simon Fraser University
>      Burnaby, British Columbia
>      Canada
>      _______________________________________________
>      torquedev mailing list
>      [3]torquedev at supercluster.org
>      [4]http://www.supercluster.org/mailman/listinfo/torquedev
> 
>      --
> 
>    David Beer | Software Engineer
> 
>    Adaptive Computing
> 
>    I just tried this on an execution queue and a routing queue and they
>    both worked. How many jobs in the queue?
>    Ken

Zero or one jobs in the queue - this is my test system.

But, this appears to be a typical case of changing too many parameters
at the same time: I had configured torque-4.1.0 with
--enable-numa-support

I now recompiled without numa support and indeed "qstat <queue>" works
fine. Thus, apparently I have that problem only when I compile with
numa support. Alas, I do not have that much experience with that so
maybe something is wrong with my numa setup. I'll keep poking around.

Cheers,
Martin


More information about the torquedev mailing list