[torquedev] Looking for help with RPMs on TORQUE 4.0

Ken Nielson knielson at adaptivecomputing.com
Mon Feb 6 11:16:51 MST 2012


----- Original Message -----
> From: "Michael Jennings" <mej at lbl.gov>
> To: torquedev at supercluster.org
> Sent: Friday, February 3, 2012 4:42:11 PM
> Subject: Re: [torquedev] Looking for help with RPMs on TORQUE 4.0
> 
> On Thursday, 02 February 2012, at 10:04:21 (-0700),
> Ken Nielson wrote:
> 
> > Are there any RPM experts out there who could look at the make rpm
> > part of TORQUE 4.0 and help us fix the holes we have in the rpm
> > build?
> 
> Here's the second half of the patch.  I've tested this one about as
> thoroughly as I can here without putting it into production, and
> everything builds and installs (and uninstalls) fine for me.
> 
> Some of these fixes will need to find their way into 2.5.x and 3.x as
> well, but I can generate separate patches for those.
> 
> HTH,
> Michael
> 
> --
> Michael Jennings <mej at lbl.gov>
> Senior HPC Systems Engineer
> High-Performance Computing Services
> Lawrence Berkeley National Laboratory
> Bldg 50B-3209E        W: 510-495-2687
> MS 050B-3209          F: 510-486-8615
> 
 
Michael,

Thanks for the patch. I am getting the following error message when I do make rpm.

rpmbuild --with syslog --define "torque_home/sdb/torque" --with scp --without pam --without drmaa -tb torque-4.0.0.tar.gz
error: Failed dependencies:
      /usr/bin/scp is needed by torque-4.0.0-1.cri.x86_64
      make is needed by torque-4.0.0-1.cri.x86_64
make: *** [rpm] Error 1

Is this something in my setup or is there an error in the script?

Ken


More information about the torquedev mailing list