[torquedev] [Bug 176] New: torque-4.0.0: HWLOC_CFLAGS and HWLOC_LIBS ignored

bugzilla-daemon at supercluster.org bugzilla-daemon at supercluster.org
Mon Apr 23 15:52:06 MDT 2012


http://www.clusterresources.com/bugzilla/show_bug.cgi?id=176

           Summary: torque-4.0.0: HWLOC_CFLAGS and HWLOC_LIBS ignored
           Product: TORQUE
           Version: 3.0.x
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P5
         Component: libtorque
        AssignedTo: dbeer at adaptivecomputing.com
        ReportedBy: siegert at sfu.ca
                CC: torquedev at supercluster.org
   Estimated Hours: 0.0


Created an attachment (id=103)
 --> (http://www.clusterresources.com/bugzilla/attachment.cgi?id=103)
patch to include HWLOC env. variables in Libifl Makefile

When configuring torque-4.0.0 with HWLOC_CFLAGS and HWLOC_LIBS set the
subsequent make fails in Libifl because those environment variables are not
used in the Makefile:

gcc -DHAVE_CONFIG_H -I. -I../../../src/include  -I../../../src/include
-DPBS_DEFAULT_FILE=\"/var/spool/torque/server_name\"
-DPBS_SERVER_HOME=\"/var/spool/torque\"  -g -DGEOMETRY_REQUESTS
-DALWAYS_USE_CPUSETS -DNUMA_SUPPORT -MT tcp_dis.o -MD -MP -MF .deps/tcp_dis.Tpo
-c -o tcp_dis.o tcp_dis.c
In file included from ../Libutils/u_lock_ctl.h:5,
                 from tcp_dis.c:101:
../../../src/include/pbs_nodes.h:98:21: error: hwloc.h: No such file or
directory
In file included from ../Libutils/u_lock_ctl.h:5,
                 from tcp_dis.c:101:
../../../src/include/pbs_nodes.h:225: error: expected specifier-qualifier-list
before ‘hwloc_bitmap_t’
make[4]: *** [tcp_dis.o] Error 1
make[4]: Leaving directory `/usr/local/src/torque-4.0.0/src/lib/Libifl'

The attached patch works for me.

- Martin

-- 
Configure bugmail: http://www.clusterresources.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the torquedev mailing list