[torquedev] [Bug 164] New: Tweaks to build Torque 2.5.9 on Solaris 10

bugzilla-daemon at supercluster.org bugzilla-daemon at supercluster.org
Mon Dec 5 05:45:35 MST 2011


http://www.clusterresources.com/bugzilla/show_bug.cgi?id=164

           Summary: Tweaks to build Torque 2.5.9 on Solaris 10
           Product: TORQUE
           Version: 2.5.x
          Platform: PC
        OS/Version: Other
            Status: NEW
          Severity: normal
          Priority: P5
         Component: libtorque
        AssignedTo: dbeer at adaptivecomputing.com
        ReportedBy: skip at pobox.com
                CC: torquedev at supercluster.org
   Estimated Hours: 0.0


Created an attachment (id=98)
 --> (http://www.clusterresources.com/bugzilla/attachment.cgi?id=98)
Allows Torque 2.5.9 to build on Solaris 10 update 9.

Needing to upgrade from 2.4.8 (because of the /dev/null bug), I decided to
try 2.5.9.  I had to make a few changes to get it to build.  In addition to
the attached unidiff, I had to edit libtool to define a variable named "echo".
It already defined "ECHO", but had references to "$echo" all over the place.
I didn't add that to the patch because that was likely a side effect of my
autoconf environment.  YMMV.

I have not yet tried the new build, but the attached changes were required to
get it to build, so I figured I'd pass it along.

-- 
Configure bugmail: http://www.clusterresources.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the torquedev mailing list