[torquedev] Release Candidate for TORQUE 2.5.8

Ken Nielson knielson at adaptivecomputing.com
Wed Aug 24 12:16:36 MDT 2011


----- Original Message -----
> From: "Glen Beane" <glen.beane at gmail.com>
> To: "Torque Developers mailing list" <torquedev at supercluster.org>
> Sent: Wednesday, August 24, 2011 12:07:59 PM
> Subject: Re: [torquedev] Release Candidate for TORQUE 2.5.8
> On Wed, Aug 24, 2011 at 1:54 PM, Ken Nielson <
> knielson at adaptivecomputing.com > wrote:
> 
> 
> There is a new release candidate for TORQUE available. This has the
> fixes for the compiler warnings with the exception of
> process_request.c, function get_creds line 288. dereferencing
> type-punned pointer will break strict-aliasing rules.
> 
> in my opinion, this is a warning that shouldn't be ignored
> indefinitely (not that anyone has suggested it). I think it would be
> good to fix before the official release. I would also add
> -fno-strict-aliasing to my CFLAGS until it were fixed.
> 
> I would volunteer to the look at the code responsible for the warning,
> but I can't guarantee I would have a chance any time soon.
> 
> _______________________________________________
> torquedev mailing list
> torquedev at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torquedev

Glen,

Thanks for volunteering. I agree with you that we should fix this but I did not want to postpone a release candidate for a warning. This particular warning only makes it so certain optimizations cannot be applied to the code. I started to look at a solution and did not see a quick fix. Like you I am busy with other priorities.

If you get time to fix this please do.

For now I propose that we do not postpone the release of 2.5.8 based on this warning.

Ken


More information about the torquedev mailing list