[torquedev] autogen on freebsd

Garrick Staples garrick at usc.edu
Fri Jul 23 17:29:46 MDT 2010


How do I generate new autotools files on freebsd? The tools aren't installed as
'autoconf', 'aclocal', etc. They are 'autoconf259, 'aclocal19', etc. The
freebsd autoreconf259 fails because it can't find aclocal.

  Can't exec "aclocal": No such file or directory at /usr/local/share/autoconf259/Autom4te/FileUtils.pm line 288.

If I run the tools by hand, it still fails with a libtool error. 
  
  configure.ac:1331: the top level
  configure.ac:218: error: possibly undefined macro: AC_PROG_LIBTOOL

And libtoolize keeps telling me to run aclocal (no matter how many times I run aclocal).

-- 
Garrick Staples, GNU/Linux HPCC SysAdmin
University of Southern California

Life is Good!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torquedev/attachments/20100723/2ef4cab4/attachment.bin 


More information about the torquedev mailing list