[torquedev] 2.5 Release

Glen Beane glen.beane at gmail.com
Thu Jul 15 10:10:54 MDT 2010


On Thu, Jul 15, 2010 at 12:08 PM, Ken Nielson
<knielson at adaptivecomputing.com> wrote:
> On 07/15/2010 09:54 AM, David Beer wrote:
>>
>> ----- Original Message -----
>>
>>> The fact that this is 2.x release implies a promise for upgrade
>>> compatibility.
>>>
>>>
>> I believe Glen and I talked about this and decided that it was okay to not be upgradeable with arrays queued because arrays have been marked as an experimental feature for the entire time. In other words, users should know that the arrays are subject to change as the website notes that they are "under development and certainly are not feature complete." (http://www.clusterresources.com/torquedocs/2.1jobsubmission.shtml)
>>
>> Also, there is a warning in the README.array_changes file. I forgot to include it in the beta release, but it is there are will be in the tarball. Also, it will be noted in the release email.
>>
>> David
>> _______________________________________________
>>
> So if the stance is that job arrays will not be backward compatible we
> will need to make it clear to users who upgrade. That means we will need
> to post it in more than one place.

I also think pbs_server should check and abort the startup process if
it detects that "old-style" job arrays are queued.  The user will then
have the option of downgrading TORQUE until the jobs arrays are done.


More information about the torquedev mailing list