[torquedev] TORQUE 2.5 beta is here!

Glen Beane glen.beane at gmail.com
Thu Jul 8 08:01:44 MDT 2010


On Thu, Jul 8, 2010 at 9:53 AM, Baer, Troy <tbaer at utk.edu> wrote:
> On Fri, 2010-07-02 at 10:51 -0600, David Beer wrote:
>> We're pleased to announce that TORQUE 2.5 beta is ready for testing.
>> It can be downloaded here:
>>
>> http://www.clusterresources.com/downloads/torque/snapshots/torque-2.5-beta_0.20100702.tar.gz
>>
>> The biggest features for 2.5 are massive improvements to the arrays
>> feature and native support for procs. By native support for procs, I
>> mean that if you qsub -l procs=2, and then do a qrun, you'll get 2
>> procs instead of TORQUE treating it as nodes=1:ppn=1.
>>
>> Please see the README.array_changes file for explanations of the new
>> features and how to use them. Glen and I have tested these features as
>> much as we can and we're confident in them, but we wanted to do some
>> more beta testing before officially releasing 2.5. Thank you to all
>> those who participated in the first round of beta testing. We ask for
>> your help in solidifying this product and moving us towards the
>> official release!
>
> I tried this beta release briefly on an SGI UV early-access system
> running SLES 11 and ran into the following:
>
> 1.  Installing the SLES libcap-devel and pam-devel RPMs were required to
> build this version of TORQUE, which was not the case with earlier
> versions.  Particularly vexing is pam-devel, as I had explicitly
> disabled PAM support at configure time and yet pam-devel was required to
> link pbs_mom.
>
> 2.  There appears to be no way to disable whatever feature turns on the
> C compiler flag -DUSEJOBCREATE -- is that intentional?
>
> 3.  On my UV, I run pbs_server and pbs_mom on the same host.  For some
> reason, pbs_server on the UV could not talk to pbs_mom on the UV and
> thus though it was down.  This was not the case with earlier releases,
> so I fell back to the 2.4.5 build I had been using previously.


I just created a TORQUE version 2.5.0_beta in bugzilla.  Can any
issues with the beta get logged against that.  (there is already a
2.5.x version in bugzilla, but lets reserve that for use with the
official release).


More information about the torquedev mailing list