[torquedev] Turning off libtool

Bas van der Vlies basv at sara.nl
Thu Dec 16 08:32:15 MST 2010


On 16-12-10 15:51, "Mgr. Šimon Tóth" wrote:
>> Hello,
>>
>>>> I'm trying to package Torque into debian packages, but libtool is
>>
>> Domique already pointed you to the Debian package that is already
>> in the distribution. You have direct access also via
>> http://svn.debian.org/wsvn/pkg-escience/torque/trunk/debian/rules
>>
>>>> re-linking binaries against nonsensical libraries which is
>>>> preventing me from creating a working package.
>>>
>>> Libtool does not link binaries against "nonsensical libraries."
>>
>> have you tried --as-needed ?
>
> No, thx for the tip.
>
>>> What is the exact behavior that you're seeing?  Most unexpected
>>> behavior on the part of libtool can be explained by the content of the
>>> various *.la files on the system in question.  These files are
>>> essentially useless on Linux for system libraries, so you might want
>>> to try backing up and removing all *.la files in /lib* and /usr/lib*.
>>> Then "make distclean" and try again.
>>
>> And if there is something to improve on the existing Debian and Ubuntu
>> packages (which actually build twice, i.e. with and without X) then
>> please communicate them back.
>
> This is local build. We have a lot of new features in our fork
> installing using configure/make would be impossible.
>

Before the debian one. There is also one at:
  - https://subtrac.sara.nl/oss/torque_2_deb

Maybe there are some useful tips/tricks

-- 
********************************************************************
*  Bas van der Vlies                    e-mail: basv at sara.nl       *
*  SARA - Academic Computing Services   Amsterdam, The Netherlands *
********************************************************************


More information about the torquedev mailing list