[torquedev] Error in init.d/pbs_mom

Joshua Bernstein jbernstein at penguincomputing.com
Mon Nov 30 16:45:04 MST 2009



Ken Nielson wrote:
> Joshua Bernstein wrote:
>> Hey Guys,
>>
>> I just pulled down the torque 2.4.2.tar.gz to work on the bug that 
>> Glen mentioned regarding mpiexec. The first thing I notice is that 
>> there is a new pbs_mom script that errors as follows:
>>
>> [root at goldstar torque]# /etc/init.d/pbs_mom status
>> /etc/init.d/pbs_mom: line 26: syntax error near unexpected token `fi'
>> /etc/init.d/pbs_mom: line 26: `fi'
>>
>> Basically the patch for the fix looks something like this:
>>
>> --- /etc/init.d/pbs_mom.orig    2009-11-30 22:08:46.000000000 -0800
>> +++ /etc/init.d/pbs_mom 2009-11-30 22:08:50.000000000 -0800
>> @@ -21,7 +21,7 @@ args=""
>>   if [ -z "$previous" ];then
>>      # being run manually, don't disturb jobs
>>      args="-p"
>> -elif
>> +else
>>      args="-q"
>>   fi
>>
>> Now while I haven't checked to see if this is fixed in the 2.4-fixes 
>> branch, this is pretty embarrassing that it was release this glaringly 
>> obviously broken.
>>
>> If its already fixed, then its not a problem, if not, I'm surprised 
>> nobody has caught it, or mentioned it yet. Either way its still silly 
>> not to catch something like this.
>>
>> Is there some sort of test plan that is in place for testing TORQUE 
>> before its released?
>>
>> -Joshua Bernstein
>> Senior Software Engineer
>> Penguin Computing
>> _______________________________________________
>> torquedev mailing list
>> torquedev at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/torquedev
>>   
> Joshua,
> 
> This has been fixed by Al it looks like.

Any idea when he fixed it?

-Josh


More information about the torquedev mailing list