[torquedev] [Patch, torque-2.1.8] init.d/suse.*; guard better against strncat buffer overflow

Garrick Staples garrick at clusterresources.com
Fri May 11 16:22:04 MDT 2007


On Fri, May 11, 2007 at 09:59:15PM +0200, Tobias Burnus alleged:
> Hello,
> 
> attached you find two diffs. One is to make the init.d/suse.* scripts
> more compatible with SUSE and the Linux Standard Base. (e.g.
> force-reload was missing, which is required by the LSB. As SUSE's
> rc_status is used this is still not a valid LSB init.d script.)
> 
> The other patch was found in
> http://software.opensuse.org/download/home:/darix/SUSE_Factory/src/torque-2.1.8-2.1.src.rpm
> and guards better against possible buffer overflows.
> 
> (Torque packages for openSUSE 10.2, Factory and SUSE Linux 10.0 and 10.1
> can be found at
> http://software.opensuse.org/download/home:/darix/ )
> 
> Tobias
> 

Thanks, I'll take a look at these.



More information about the torquedev mailing list