[torquedev] [Patch, torque-2.1.8] init.d/suse.*; guard better against strncat buffer overflow

Tobias Burnus burnus at net-b.de
Fri May 11 13:59:15 MDT 2007


attached you find two diffs. One is to make the init.d/suse.* scripts
more compatible with SUSE and the Linux Standard Base. (e.g.
force-reload was missing, which is required by the LSB. As SUSE's
rc_status is used this is still not a valid LSB init.d script.)

The other patch was found in
and guards better against possible buffer overflows.

(Torque packages for openSUSE 10.2, Factory and SUSE Linux 10.0 and 10.1
can be found at
http://software.opensuse.org/download/home:/darix/ )


-------------- next part --------------
A non-text attachment was scrubbed...
Name: torque-2.1.8_init.d_compat.patch
Type: text/x-patch
Size: 4776 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torquedev/attachments/20070511/d2ad930a/torque-2.1.8_init.d_compat.bin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: torque-2.1.6_bad_strncat_usage.patch
Type: text/x-patch
Size: 2251 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torquedev/attachments/20070511/d2ad930a/torque-2.1.6_bad_strncat_usage.bin

More information about the torquedev mailing list