[torquedev] change in torque distribution (automake)

Garrick Staples garrick at clusterresources.com
Thu Apr 12 16:22:10 MDT 2007


On Thu, Apr 12, 2007 at 11:42:00PM +0200, Standa Kunc alleged:
> I am working with Torque 2.1.6 original revision number 1147. And I
> should be able to regenerage makefiles and configure but there are
> some errors and it fails.
> 
> I have ubuntu distribution, all tools are installed:
> autoconf (GNU Autoconf) 2.60
> automake (GNU automake) 1.4-p6
> ltmain.sh (GNU libtool) 1.5.22 Debian 1.5.22-4 (1.1220.2.365
> 2005/12/18 22:14:06)

Maybe your automake is too old?
$  rpm -q automake automake libtool
autoconf-2.59-5
automake-1.9.2-3
libtool-1.5.6-4.EL4.1.c4.4

 
> Is there some special way to build torque distribution? Do I have to
> change some parameters in configuration?

Nothing special at all.  I typically just run 'autoreconf -v -f -i'

If you don't have autoreconf, I'd try this:
aclocal --force
libtoolize --copy --force
autoconf --force
autoheader --force
automake --add-missing --copy --force-missing

 
> src/gui/Makefile.am:33: invalid variable `dist_xpbshelp_DATA'
> src/gui/Makefile.am:17: invalid variable `dist_xpbs_DATA'
> src/gui/Makefile.am:26: invalid variable `dist_xpbsbitmap_DATA'
> src/gui/Makefile.am:12: invalid variable `nodist_xpbs_DATA'
> automake: src/lib/Libpbs/Makefile.am: not supported: source file
> `../Libdis/dis.c' is in subdirectory
> automake: src/lib/Libpbs/Makefile.am: not supported: source file
> `../Libdis/discui_.c' is in subdirectory

I imagine this is a pretty good indication of an older automake.



More information about the torquedev mailing list