[torquedev] Latest snapshot won't start - "unable to read tracksize from tracking file"

Dave Jackson jacksond at clusterresources.com
Thu Jan 12 23:18:50 MST 2006


  The system call checking has been adjusted and a new snap released.
Things seem to be working now.  Let us know what you find.


On Fri, 2006-01-13 at 16:42 +1100, Chris Samuel wrote:
> Hi folks,
> Just tried the latest snapshot, torque-2.0.0p6-snap.1137121187, and found that
> it will no longer start, I get the error:
> PBS_Server: No such file or directory (2) in pbs_init, unable to read tracksize from tracking file
> PBS_Server: PBS_Server, pbsd_init failed
> Using strace I see that it's trying to open /usr/spool/PBS/server_priv/tracking
> which was empty, so I rm'd it in case it needed to create it itself and restarted
> PBS but found that it failed with the same error after recreating that file. :-(
> Looking at the code that is involved in pbsd_init.c it seems that the file is
> opened with O_CREAT but there are no checks for it existing prior to this
> and so it is never initialised to the size that pbs_server seems to be
> expecting.
> My guess would be that you'd want to drop the O_CREAT and if that open
> fails then create it with the correct size ?
> This is on Fedora Core 3 on IA32, very vanilla..
> cheers,
> Chris
> _______________________________________________
> torquedev mailing list
> torquedev at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torquedev

More information about the torquedev mailing list