[Mauiusers] SIGSTOP and SIGTSTP don't work

skip at pobox.com skip at pobox.com
Sat Jan 15 09:01:31 MST 2011


    Mahmood> I tried with both jobID (returned from qstat) and processID
    Mahmood> (returned from top) but none of them worked:

You are dealing two completely independent sets of ids and the commands
which operate on them:

    * The job id is an identifier assigned by Torque.  You can only use
      Torque or Maui commands to manipulate it.  Those commands include the
      Torque qdel command and the Maui canceljob command.  (I am not really
      much of a Torque/Maui user.  I wouldn't be surprised if there were
      more such commands.)  You can use the job id you found in the qstat
      command with them.

    * The process id is an identifier assigned by the operating system to
      the process when it's created by a fork() system call.  You found the
      process id in the output of top, but you could have also used the ps
      command.  The kill command operates on process ids, not Torque job
      ids.

You can'd mix and match commands from one arena with the ids from another.
This explains why you couldn't kill the process using a fragment of the
Torque job id:

    Mahmood> mahmood at server:~$ kill -SIGSTOP 816
    Mahmood> -bash: kill: (816) - No such process
    Mahmood> mahmood at server:~$ kill -SIGSTOP 26900 
    Mahmood> -bash: kill: (26900) - No such process

It also explains why executing 'kill -SIGSTOP process-id' has no effect on
the run status of your Torque job.  Torque has no knowledge that you paused
the underlying process, so it continues to treat the job as 'R'unning.

There is a Torque command named 'qhold' which will hold running Torque jobs.
Try 'man qhold'.

Skip


More information about the mauiusers mailing list