[Mauiusers] Maui and Torque on OSX 10.6 not communicating properly

Byron Millet byronmillet at hotmail.com
Fri Aug 5 13:09:17 MDT 2011


Per some suggestions I received, I have examined the /var/spool/torque/server_priv/nodes and /etc/hosts files, but I have not found anything that could cause a problem.
Here are the contents of these files.
/etc/hosts:127.0.0.1     localhost   localhost.localdomain255.255.255.255     broadcasthost::1     localhostfe80::1%lo0     localhost
xxx.xxx.xxx.xxx galaxy galaxy.physics.weber.edu

/var/spool/torque/server_priv/nodes:galaxy.physics.weber.edu np=4 galaxy


I have tried altering the hosts file so that the long name (galaxy.physics.weber.edu) appears before the short name.I have also tried moving that entry to the top of the file.
Additionally, I have tried altering the nodes file so that the short name appears first.Nothing has helped.
I am able to run jobs fine (I am using the pbs_sched scheduler), but the maui scheduler in TEST mode is unable to communicate with the pbs daemons.
If anyone has any ideas, please let me know.
I am going to recompile the maui scheduler, but I am not sure how that will help.
Byron



From: byronmillet at hotmail.com
To: mauiusers at supercluster.org
Date: Mon, 1 Aug 2011 14:36:17 -0600
Subject: [Mauiusers] Maui and Torque on OSX 10.6 not communicating properly








Hello,
I am setting up the resource management and scheduling software for a 32 node cluster for the Weber State University physics department and I have been trying to get Maui to communicate with the Torque RM for a few weeks without any success.
The current setup is with only one node running the pbs_server, pbs_mom, and pbs_sched daemons.I am able to run jobs using this setup with no problems.

I have Maui set to test mode to see if it is communicating properly, but the maui.log file just shows among other things:MRMClusterQuery()WARNING: no resources detected MRMWorkloadQuery()WARNING: no workload detected
This is with LOGLEVEL 3When I change LOGLEVEL to 9I see several ALERTS such as:
MRMInitialize()ALERT: cannot initialize RM (RM '0' does not support function 'rminitialize')INFO:  XRMInitialize not supported
and 
MRMClusteruery()ALERT: cannot load cluster resources on RM (RM '0' does not support function 'clusterquery')WARNING: no resources detected


I have the RM defined in the maui.cfg file as follows:RMCFG[0] TYPE=PBS
I have also tried the following definitions:
RMCFG[galaxy.physics.weber.edu] TYPE=PBS


none of the diagnose commands seem to show anything useful.diagnose -n shows no nodes presentdiagnose -R shows:RM[0] type: 'PBS'  state: '[NONE]'  Event Management: (event interface disabled)


I have read through the Maui admin guide and the Torque admin guide several times and can't seem to find any new ideas to try.
If anyone has any ideas, please let me know.
Thanks,
Byron Millet



 		 	   		  

_______________________________________________
mauiusers mailing list
mauiusers at supercluster.org
http://www.supercluster.org/mailman/listinfo/mauiusers 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/mauiusers/attachments/20110805/692bf68e/attachment.html 


More information about the mauiusers mailing list