[Mauiusers] Build issues on Solaris

skip at pobox.com skip at pobox.com
Wed Apr 6 14:37:49 MDT 2011


Maui doesn't build out-of-the-box on Solaris 10.  I tried a couple S10
variants (update 5 and update 9) and a couple different versions of gcc (4.2
and 4.4).  Configure complains:

    configure: WARNING: Unsupported OS: SunOS, attempting build with OPSYS=__LINUX

When I forge ahead and execute make anyway I get an error trying to compile
MUtil.c (with gcc 4.4):

    gcc -I../../include/ -I/var/spool/maui/include     -I/var/opt/torque/include -D__LINUX   -D__MPBS       -g -O2  -c MUtil.c
    MUtil.c: In function 'MUGetPeriodStart':
    MUtil.c:4130: error: 'struct tm' has no member named 'tm_gmtoff'
    make[1]: *** [MUtil.o] Error 1

Maui 3.2.6p21, 3.3 and 3.3.1 all fail to build in the same way.  That code
is guarded by an #idef __LINUX directive.

Looking in configure I saw no mention of Solaris in the "Determine OPSYS"
section.  Is there some reason adding this fragment of code

    elif test "$OS" = "SunOS"; then
      OPSYS="__SOLARIS"

shouldn't work (with obligatory changes to LDFLAGS to pick up the socket and
nsl libraries)?  I see a few mentions of __SOLARIS in the code, MUtil.c
compiles cleanly when you don't lie to it about the OS it's being built on,
and with the socket and nsl libraries included, everything links okay.

Am I missing something?  Why would HP-UX, IRIX and AIX be supported but
Solaris not?

-- 
Skip Montanaro - skip at pobox.com - http://www.smontanaro.net/


More information about the mauiusers mailing list