[Mauiusers] Torque-2.5.3 and Maui-3.3 problem with jobs where ppn parameter is grater than 1

Piotr Brona pbrona at gmail.com
Fri Nov 26 08:15:57 MST 2010


Hello,

My configuration:

maui-3.3 - compiled with --with-pbs=/usr parameter
torque-2.5.3
openmpi-1.4 - compiled with --with-tm=/usr parameter

I have a problem with jobs where the ppn parameter is grater than 1. For 
example if I run job with '-l nodes=3:ppn=1' everything is fine and the 
result of 'showq -n1' looks like that:


ori1:
                                                                          Req'd  Req'd   Elap
Job ID               Username Queue    Jobname          SessID NDS   TSK 
Memory Time  S Time
-------------------- -------- -------- ---------------- ------ ----- --- 
------ ----- - -----
118.ori1             pbrona   simple   job_3x1.sh         4305     3   
3    1gb 00:20 R   --
    ori4/0+ori3/0+ori2/0


but when i try run job with '-l nodes=3:ppn=2' job runs only on 1 node 
and the result is


ori1:
                                                                          Req'd  Req'd   Elap
Job ID               Username Queue    Jobname          SessID NDS   TSK 
Memory Time  S Time
-------------------- -------- -------- ---------------- ------ ----- --- 
------ ----- - -----
119.ori1             pbrona   simple   job_3x2.sh         8649     3   
6    1gb 00:20 R   --
    ori2/1+ori2/0


Below is my maui.cfg config file:

# maui.cfg 3.3

SERVERHOST        ori1
ADMIN1            root

RMCFG[ori1]        TYPE=PBS

RMPOLLINTERVAL        00:00:10

SERVERPORT        40559

SERVERMODE        NORMAL

LOGFILE            /var/spool/maui/logs/maui.log
LOGFILEMAXSIZE        100000000
LOGLEVEL        7

QUEUETIMEWEIGHT        1

BACKFILLPOLICY        FIRSTFIT
RESERVATIONPOLICY    CURRENTHIGHEST

NODEALLOCATIONPOLICY    MINRESOURCE

ENABLEMULTIREQJOBS    TRUE
ENABLEMULTINODEJOBS    TRUE

JOBNODEMATCHPOLICY    EXACTNODE

NODEACCESSPOLICY    SHARED


I read about ENABLEMULTIREQJOBS and JOBNODEMATCHPOLICY parameter and I 
set it, but when I run 'showconfig' it shows only


NODELOADPOLICY                  ADJUSTSTATE
JOBNODEMATCHPOLICY[1]

JOBMAXSTARTTIME[1]                  INFINITY

METAMAXTASKS[1]                   0
NODESETPOLICY[1]                  [NONE]
NODESETATTRIBUTE[1]               [NONE]
NODESETLIST[1]
NODESETDELAY[1]                   00:00:00
NODESETPRIORITYTYPE[1]            MINLOSS
NODESETTOLERANCE[1]                 0.00

# Priority Weights

XFMINWCLIMIT[1]                   00:00:00

RMAUTHTYPE[0]                     CHECKSUM

CLASSCFG[route]  DEFAULT.FEATURES=[NONE]
QOSPRIORITY[0]                    0
QOSQTWEIGHT[0]                    0
QOSXFWEIGHT[0]                    0
QOSTARGETXF[0]                      0.00
QOSTARGETQT[0]                    00:00:00
QOSFLAGS[0]
QOSPRIORITY[1]                    0
QOSQTWEIGHT[1]                    0
QOSXFWEIGHT[1]                    0
QOSTARGETXF[1]                      0.00
QOSTARGETQT[1]                    00:00:00
QOSFLAGS[1]
RESDEPTH                        24

SCHEDCFG[]                        MODE=NORMAL SERVER=ori1:40559
# RM MODULES: PBS SSS WIKI NATIVE
  TYPE=PBS
SIMEXITITERATION                -1


and the parameters ENABLEMULTIREQJOBS and JOBNODEMATCHPOLICY are not set :(
I try use 'changeparam' command but there change in maui and torque 
behaviour.


Please help me resolve my problem.

Best Regards
Piotr Brona


More information about the mauiusers mailing list