[Mauiusers] Nodes have 8gb memory, maui shows less

Simon Brennan simon.brennan at ersa.edu.au
Wed Jul 28 20:30:52 MDT 2010


Hi All

Thank you for the replies.

You're completely right. When you divide the memory from kb to mb it is 
correct and slightly less than 8GB.
It seemed weird as the old Openpbs 2.0 that was running on there allowed 
you to ask for 8GB of RAM.
Must have been a fluke that it worked.

I think that the onboard ATI graphics cards are stealing a small amount 
of memory from the system which could account for them having slightly 
less than 8GB. Also as mentioned some of the memory is reserved for the OS.

Thanks for answering my non maui, non torque question :)

Regards

Simon Brennan

System Administrator
eResearchSA
University of Adelaide
North Terrace Campus
Physics Building
Room 114d


On 07/29/2010 12:42 AM, Michel Béland wrote:
> Hello,
>
>    
>> I'm running torque 2.3.7 and maui 3.2.6.
>> Everything appears to working fine. I can submit jobs and they run
>> successfully.
>> I'll dump my configs, if required.
>>
>> I've got this weird problem where my nodes have 8GB of RAM, however when
>> I submit jobs to torque that request mem=8gb, they are never started by
>> maui. If I was to submit the same job to torque and request mem=7900mb,
>> maui will then start the job.
>>      
> This is perfectly normal.
>
>    
>> Pbsnodes in torque shows 8GB of memory:
>>
>>        state = free
>>        np = 8
>>        properties = corvus
>>        ntype = cluster
>>        status = opsys=linux,uname=Linux 2.6.16.46-0.12-smp #1 SMP Thu May
>> 17 14:00:09 UTC 2007 x86_64,sessions=? 0,nsessions=?
>> 0,nusers=0,idletime=0,totmem=24563472kb,availmem=24433724kb,physmem=8179480kb,ncpus=8,loadave=0.00,netload=28007785,state=free,jobs=,varattr=,rectime=1280298000
>>      
>
> No, this is not 8 GB, but 8179480 KB, which is *not* the same. As 1 MB =
> 1024 KB and 1 GB = 1024 KB, this means that 8179480 KB is 7987,7734 MB
> and is also 7,80056 GB. You have to remember that the OS takes some
> memory that is not available to programs. If you type the command "free"
> on this compute node, you will see that you do not have the full 8 GB
> available.
>
>    
>> But when I run the maui command checknode it shows:
>>
>> checking node
>> State:      Idle  (in current state for 00:10:08)
>> Configured Resources: PROCS: 8  MEM: 7987M  SWAP: 23G  DISK: 1M
>>      
> So Maui shows the same memory as pbsnodes, but rounded down to integer
> megabytes.
>
>    
>> Does anyone have an idea why maui seems to show slightly less than 8GB
>> or rather 8000mb?
>> Is this a problem with maui, or should I be looking at torque instead?
>>      
> That is how Linux works (and probably other Unix systems too).
>
>    


More information about the mauiusers mailing list