[Mauiusers] Nodes have 8gb memory, maui shows less

Simon Brennan simon.brennan at ersa.edu.au
Wed Jul 28 00:33:25 MDT 2010


Hi All

I'm running torque 2.3.7 and maui 3.2.6.
Everything appears to working fine. I can submit jobs and they run 
successfully.
I'll dump my configs, if required.

I've got this weird problem where my nodes have 8GB of RAM, however when 
I submit jobs to torque that request mem=8gb, they are never started by 
maui. If I was to submit the same job to torque and request mem=7900mb, 
maui will then start the job.

Pbsnodes in torque shows 8GB of memory:

      state = free
      np = 8
      properties = corvus
      ntype = cluster
      status = opsys=linux,uname=Linux 2.6.16.46-0.12-smp #1 SMP Thu May 
17 14:00:09 UTC 2007 x86_64,sessions=? 0,nsessions=? 
0,nusers=0,idletime=0,totmem=24563472kb,availmem=24433724kb,physmem=8179480kb,ncpus=8,loadave=0.00,netload=28007785,state=free,jobs=,varattr=,rectime=1280298000

But when I run the maui command checknode it shows:

checking node
State:      Idle  (in current state for 00:10:08)
Configured Resources: PROCS: 8  MEM: 7987M  SWAP: 23G  DISK: 1M
Utilized   Resources: [NONE]
Dedicated  Resources: [NONE]
Opsys:         linux  Arch:      [NONE]
Speed:      1.00  Load:       0.000
Network:    [DEFAULT]
Attributes: [Batch]
Classes:    [ 8:8]

Total Time: 1:28:56  Up: 1:28:56 (100.00%)  Active: 00:11:21 (12.76%)

Reservations:
NOTE:  no reservations on node

Does anyone have an idea why maui seems to show slightly less than 8GB 
or rather 8000mb?
Is this a problem with maui, or should I be looking at torque instead?

Thanks for your time.

Regards

-- 
Simon Brennan

System Administrator
eResearchSA
University of Adelaide
North Terrace Campus
Physics Building
Room 114d





More information about the mauiusers mailing list