[Mauiusers] #PBS -l qos=something or qsub -l qos=something doesn't seem to work with torque 2.4.3 and maui 3.2.6p21

Sabuj Pattanayek sabujp at gmail.com
Thu Feb 18 17:05:27 MST 2010


HI,

I basically have the same problem as described here:

http://www.supercluster.org/pipermail/mauiusers/2009-April/003817.html

using torque 2.4.3 and maui 3.2.6p21 . I have a definition like this:

QOSCFG[noht] QFLAGS=DEDICATED

Where I'm giving users the option to be the only job on a node. Lines
like #PBS -l qos=noht in .pbs files or run from the command line with
"qsub -l qos=noht job.pbs" end up using the DEFAULT qos. I can "setqos
noht jobid" after running the job but that leaves open the possibility
that someone else's job starts running on the node immediately after
my job starts running. I also thought about running "setqos noht
$PBS_JOBID" from inside the .pbs file but that would probably cause
the same race condition between my job and other jobs. I also don't
know if maui commands would work from nodes that are only running the
pbs_mom.

It seems that only when I specify QDEF=noht for USERCFG, GROUPCFG,
ACCOUNTCFG, or CLASSCFG does it always start the specified qos, but
again I want to be able to specify this qos at job submission time
without adding a "noht" account (which would mess up my fairshare
configurations). I guess the best work around for now would be to
create a noht queue and have it QDEF'd to that CLASS?

Thanks,
Sabuj Pattanayek


More information about the mauiusers mailing list