[Mauiusers] [torqueusers] Maui-Torque integration problems

Jim Kusznir jkusznir at gmail.com
Thu Dec 10 09:34:12 MST 2009


Ok, I increased the logging level and tried the various definations of
RMCFG suggested by others; no chage or helpful results.

I think this is the crux of the problem (loglevel 5):

12/10 08:20:49 MRMWorkloadQuery()
12/10 08:20:49 MPBSWorkloadQuery(ISP-CURRAN.ISP.WSU.EDU,JCount,SC)
12/10 08:20:49 INFO:     queue is empty
12/10 08:20:49 INFO:     0 PBS jobs detected on RM ISP-CURRAN.ISP.WSU.EDU
12/10 08:20:49 WARNING:  no workload detected

Just a few lines above that, it does:
12/10 08:20:49 MRMClusterQuery()
12/10 08:20:49 MPBSClusterQuery(ISP-CURRAN.ISP.WSU.EDU,RCount,SC)
12/10 08:20:49 __MPBSGetNodeState(Name,State,PNode)
12/10 08:20:49 INFO:     PBS node isp-curran set to state Idle (free)

And correctly detects my resources and their states.

So maui is clearly able to talk to torque, its just not able to load
the list of jobs.  It does load the compute resources just fine.  Does
maui use a different method/connection to load jobs from the scheduler
(i.e., a different network port to torque, etc)?

Thanks!
--Jim

On Wed, Dec 9, 2009 at 7:23 PM, Garrick Staples <garrick at usc.edu> wrote:
> On Wed, Dec 09, 2009 at 05:49:19PM -0800, Jim Kusznir alleged:
>> I just completely replaced my torque install with a fresh build using
>> the RPM, getting the home dir in /opt/torque with the rest of the
>> torque stuff, and all.  I reconfigured torque from scratch as part of
>> the process, but still no go.  Here is a summary of all my configs:
>
> Forget about torque, it is working fine. It is queueing jobs and you can see
> jobs in qstat. It is working fine.
>
> The problem is Maui isn't loading jobs.
>
> Increase the loglevel in maui and hopefully you will see some sort of error in
> the maui log.
>
>
> _______________________________________________
> mauiusers mailing list
> mauiusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/mauiusers
>
>


More information about the mauiusers mailing list