[Mauiusers] Jobs going into incorrect queue

Steve Young chemadm at hamilton.edu
Tue Apr 21 13:18:33 MDT 2009


Hi,
	I use a server default for torque.....

set server resources_default.walltime = 24:00:00

This way if they don't specify anything they will default to 24  
hours.  I took the approach that if the user doesn't specify anything  
that they should get a minimal amount of queue time. With this I don't  
have to have a queue to handle unspecified. I'd rather have their job  
finish fairly quick and realize they didn't specify a time than to  
have them go for days/weeks before they realized they didn't specify  
it. I'd hate to have a job run for two weeks and then end up getting  
killed off because I didn't specify my time. Especially for a job that  
can't pick up where it left off and has to start from the beginning  
again. Seems like a waste of resources to me. Not sure if this helps  
you any. Could you send the output of the rest of the qmgr output?  
It's hard to tell why it's getting to the unspec queue if we can't see  
the config for it.

-Steve



On Apr 21, 2009, at 1:06 PM, Philip Peartree wrote:

> The default queue is the routing queue, which should place the job
> based on allowed time, that is why it's so puzzling that the jobs end
> up in the short_2h queue, as they should be rejected by that and
> others until it reaches the unspec queue.
>
>
> Quoting "Greenseid, Joseph M (IS)" <Joseph.Greenseid at ngc.com>:
>
>> have you tried to set the default queue (set server default_queue =
>> unspec) in qmgr?  this is how i route jobs that don't specify
>> resources to a default location...
>>
>> --Joe
>>
>> ________________________________
>>
>> From: mauiusers-bounces at supercluster.org on behalf of Philip Peartree
>> Sent: Tue 4/21/2009 12:32 PM
>> To: torqueusers at supercluster.org; mauiusers at supercluster.org
>> Subject: [Mauiusers] Jobs going into incorrect queue
>>
>>
>>
>> Hi Guys
>>
>> I have a problem that jobs appear to be not routing to the correct
>> queue. My set up is as follows:
>>
>> routing queue
>> 2h queue
>> 12h queue
>> 1w queue
>> unspecified time queue (max time 2w)
>> guest queue (low priority)
>>
>> If a time is unspecified at job submission a default time of 2w  
>> (336h) is set
>>
>> The routing queue is setup as follows (as taken from qmgr -c 'print  
>> server')
>>
>> create queue route
>> set queue route queue_type = Route
>> set queue route route_destinations = short_2h
>> set queue route route_destinations += med_12h
>> set queue route route_destinations += long_1w
>> set queue route route_destinations += unspec
>> set queue route route_destinations += guest
>> set queue route enabled = True
>> set queue route started = True
>>
>> my problem is that some jobs with unspecified time (which have
>> correctly been given a time of 336h) are ending up in the short_2h
>> queue, which has a higher priority than other queues. Does anyone  
>> know
>> of any possible explanation for this?
>>
>> Phil Peartree
>> University of Manchester
>>
>> _______________________________________________
>> mauiusers mailing list
>> mauiusers at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/mauiusers
>>
>>
>>
>
>
>
> _______________________________________________
> mauiusers mailing list
> mauiusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/mauiusers



More information about the mauiusers mailing list