[Mauiusers] Floating resources not working properly

Wickliffe, Blake W blake.wickliffe at aramco.com
Mon Apr 13 22:24:20 MDT 2009



Hi Troy,

Actually, I tried that.  I ran into two very severe limitations.  First, it won't let me specify more than 3 different resources...any more than that and it ignores them.  We have 8(!!!) different tape types.  Also, even when I got 2 tape types working, using the method you described, consumption doesn't work beyond the first resource.  Ie, if I have 5 type atl4 tapes, and submit six job, you get the expected behavior.  5 jobs run, and the sixth is queued.  However, when you submit 6 jobs asking for the second tape type, atl5, all 6 queue up and never run.

Very bizarre.

As for the "qsub -W x=GRES:atl4", unfortunately that didn't do anything either.  So far the only secret sauce is "software=XXX".  :(

Blake Wickliffe
Saudi Aramco
ENOD/CSYS/USG HPC Team
(873-4417)

-----Original Message-----
From: Troy Baer [mailto:tbaer at utk.edu]
Sent: Monday, April 13, 2009 4:35 PM
To: Wickliffe, Blake W
Cc: mauiusers at supercluster.org
Subject: Re: [Mauiusers] Floating resources not working properly

On Mon, 2009-04-13 at 15:14 +0300, Wickliffe, Blake W wrote:
> I'm having a strange problem with global floating consumable resources in Maui.  I am trying to share a group of tape drives with a number of nodes.
>
> I've added the following line to maui.cfg
>
> NODECFG[GLOBAL]  GRES=atl4:5,atl5:5
>
> When I do a "checknode GLOBAL", I get:
>
> checking node GLOBAL
>
> State:      Idle  (in current state for 00:00:04)
> Configured Resources: atl4: 5
> Utilized   Resources: [NONE]
> Dedicated  Resources: [NONE]
> Opsys:        [NONE]  Arch:      [NONE]
> Speed:      0.00  Load:       0.000
> Features:   [NONE]
> Classes:    [NONE]
>
> Reservations:
> NOTE:  no reservations on node
>
>
> In other words, the second resource (atl5) doesn't show up at all!
>
> I am running maui version 3.2.6p21, on RHEL4u5 2.6.9-55.ELsmp.

I ran into something like this just last week.  A workaround which
worked for me was to specify each resources separately, e.g.:

NODECFG[GLOBAL]  GRES=atl4:5
NODECFG[GLOBAL]  GRES=atl5:5

This clearly doesn't agree with what's in the documentation, but it
works.

> As an additional issue, when I only specify 1 GRES, ie:
>
> NODECFG[GLOBAL]  GRES=atl4:5
>
> I cannot reserve that resource using qsub -l gres=atl4.  The only way
> that seems to work is qsub -l software=atl4.

What about "qsub -W x=GRES:atl4"?

        --Troy
--
Troy Baer, HPC System Administrator
National Institute for Computational Sciences, University of Tennessee
http://www.nics.tennessee.edu/
Phone:  865-241-4233

The contents of this email, including all related responses, files and attachments transmitted with it (collectively referred to as "this Email"), are intended solely for the use of the individual/entity to whom/which they are addressed, and may contain confidential and/or legally privileged information. This Email may not be disclosed or forwarded to anyone else without authorization from the originator of this Email. If you have received this Email in error, please notify the sender immediately and delete all copies from your system. Please note that the views or opinions presented in this Email are those of the author and may not necessarily represent those of Saudi Aramco. The recipient should check this Email and any attachments for the presence of any viruses. Saudi Aramco accepts no liability for any damage caused by any virus/error transmitted by this Email.


More information about the mauiusers mailing list