[Mauiusers] Floating resources not working properly

Troy Baer tbaer at utk.edu
Mon Apr 13 07:35:02 MDT 2009


On Mon, 2009-04-13 at 15:14 +0300, Wickliffe, Blake W wrote:
> I'm having a strange problem with global floating consumable resources in Maui.  I am trying to share a group of tape drives with a number of nodes.
> 
> I've added the following line to maui.cfg
> 
> NODECFG[GLOBAL]  GRES=atl4:5,atl5:5
> 
> When I do a "checknode GLOBAL", I get:
> 
> checking node GLOBAL
> 
> State:      Idle  (in current state for 00:00:04)
> Configured Resources: atl4: 5
> Utilized   Resources: [NONE]
> Dedicated  Resources: [NONE]
> Opsys:        [NONE]  Arch:      [NONE]
> Speed:      0.00  Load:       0.000
> Features:   [NONE]
> Classes:    [NONE]
> 
> Reservations:
> NOTE:  no reservations on node
> 
> 
> In other words, the second resource (atl5) doesn't show up at all!
> 
> I am running maui version 3.2.6p21, on RHEL4u5 2.6.9-55.ELsmp.

I ran into something like this just last week.  A workaround which
worked for me was to specify each resources separately, e.g.:

NODECFG[GLOBAL]  GRES=atl4:5
NODECFG[GLOBAL]  GRES=atl5:5

This clearly doesn't agree with what's in the documentation, but it
works.

> As an additional issue, when I only specify 1 GRES, ie:
> 
> NODECFG[GLOBAL]  GRES=atl4:5
> 
> I cannot reserve that resource using qsub -l gres=atl4.  The only way
> that seems to work is qsub -l software=atl4.

What about "qsub -W x=GRES:atl4"?

	--Troy
-- 
Troy Baer, HPC System Administrator
National Institute for Computational Sciences, University of Tennessee
http://www.nics.tennessee.edu/
Phone:  865-241-4233


More information about the mauiusers mailing list