[Mauiusers] All processes run on the head/master node

Gus Correa gus at ldeo.columbia.edu
Fri Nov 28 13:00:49 MST 2008

Hello Pascual and list

Pascual, did you configure your Torque/PBS server?

Your nodes file,
/opt/torque/server_priv/nodes (or equivalent path)
should have the nodes you want to use, and how many CPUs (or cores) they 
Something more or less like this:

my_master_node.local          np=2         #(only if you want the master 
node to run jobs also)
my_compute_node_01.local np=2
my_compute_node_02.local np=2

You also need to restart the Torque/PBS server after you change the 
nodes file.


Gus Correa

Gustavo J. Ponce Correa, PhD - Email: gus at ldeo.columbia.edu
Lamont-Doherty Earth Observatory - Columbia University
P.O. Box 1000 [61 Route 9W] - Palisades, NY, 10964-8000 - USA

Pascual Muñoz Muñoz wrote:

> Hi all,
> We are assembling a cluster following:
> http://debianclusters.cs.uni.edu/
> Right now we have a master/head node and a cluster/compute node. Both 
> are listed in the configuration files (torque pbs nodes and maui 
> machines.LINUX) to have 2 processors.
> When we send jobs to the queue through a script like:
> #!/bin/bash
> #PBS -l nodes=2
> cd /home/justme/
> mpirun -machinefile $PBS_NODEFILE -np 4 /usr/bin/whatever
> The 4 processes run on the master node! And the cluster node is free!
> On other clusters, this works fine, so the problem is not in the 
> program being run, rather in the torque/maui (we guess) configuration.
> So we did something wrong in configuration, but can't guess what. All 
> your ideas will be welcomed.
> Thanks in advance.

More information about the mauiusers mailing list