[Mauiusers] Maui erratic behaviour in picking CLASS priority values

Virendra Pratap. Singh vpsingh at yahoo-inc.com
Wed Jun 4 01:30:25 MDT 2008


Hi All,

 

  We are using maui 3.2.6p16 and it seems to be displaying some erratic
behavior with regards to picking up the Priority value for class weight
(queue).  We have multiple queues defined on torque and each of them
assigned a priority. Our processes submit the jobs to the cluster via
qsub. When I do 'mdiag -p' to see the priorities assigned to various
queued jobs sometimes I see that for some queues maui has picked class
priority as 0 (even though it has proper priority assigned) and
calculated the priority based just on queue time (we have this enabled
too). 

     Picking 0 priority for a queue is not consistent. After sometime it
may pick its correct priority value and may mess with some other queue
for which it earlier picked correct value.

 

I even tried setting the queue priority values directly in maui.cfg
"CLASSCFG[<queue-name>] PRIORITY=XYZ" (as this would override any queue
priority setting via torque). However this too has not worked and maui
remains erratic in picking up CLASS (queue) priority values.

 

Any suggestion what may be wrong or anyone experienced similar behavior.

 

Regards,

Virendra

     

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/mauiusers/attachments/20080604/b8416830/attachment.html


More information about the mauiusers mailing list