[Mauiusers] load balance problem

qq w wangqqing at gmail.com
Tue Oct 9 04:15:25 MDT 2007


Dear Maui users,
  I am new to PBS, and I got a problem in load balance when running a job
with two compute nodes.
I want to distribute a job into two compute nodes by typing :
qsub -l nodes=2 myjob.sh

'pbsnodes -a' shows that both the nodes are working:

-------------------------------
oscarnode1
     state = job-exclusive
     np = 1
     ntype = cluster
     jobs = 0/141.oscarserver.privatedomain
     status = opsys=linux,uname=Linux oscarnode1.privatedomain
2.6.11-1.1369_FC4smp #1 SMP Thu Jun 2 23:08:39 EDT 2005 i686,sessions=?
0,nsessions=?
0,nusers=0,idletime=1956,totmem=1006628kb,availmem=984676kb,physmem=506640kb,ncpus=1,loadave=
0.00,netload=236939874,state=free,jobs=141.oscarserver.privatedomain
,rectime=1191972909

oscarnode2
     state = job-exclusive
     np = 1
     ntype = cluster
     jobs = 0/141.oscarserver.privatedomain
     status = opsys=linux,uname=Linux dchen-linux 2.6.11-1.1369_FC4 #1 Thu
Jun 2 22:55:56 EDT 2005 i686,sessions=2255 24746 29308
29427,nsessions=4,nusers=3,idletime=1484,totmem=1563892kb,availmem=705020kb,physmem=515324kb,ncpus=1,loadave=
1.20,netload=2678038614,state=free,jobs=141.oscarserver.privatedomain
,rectime=1191
------------------------------

But,  cluster monitor shows : node1 is idle , while node2's CPU and memory
resource is almost 100% occupied.
How can I solve the load balancing problem?

Thanks for reply!
-- 
−−−−−−
Best regards,
          Qingqing Wang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/mauiusers/attachments/20071009/4ee7d358/attachment.html


More information about the mauiusers mailing list