[Mauiusers] Torque + Maui post installation problem

Garrick Staples garrick at usc.edu
Tue Nov 20 11:21:08 MST 2007


On Mon, Nov 19, 2007 at 07:02:23PM +0100, Luca Telloli alleged:
> Hello everyone, 
> 	I'm trying to install Maui + Torque on an experimental 3 nodes cluster,
> but I'm having problem and I haven't been able to find a solution yet. 
> 
> I installed Torque and I run pbs_mom with custom ports (10551 & 10552)
> on the three nodes to comply to local firewall policies. On one of the
> three I've installed pbs_server and properly configured it, in such a
> way that pbsnodes -a always gives me a meaningful output. 
> 
> Then I installed Maui from scratch on the same node of the pbs_server; I
> run it and it seems to work properly (for example, bin/showconfig shows
> the expected output). 
> 
> But when I run a job, specifically a test job like echo "sleep 30"|qsub,
> it remains queued on the pbs queue (in state Q) and displays the
> following warning on the MAUI log: 
> 
> 11/19 18:10:11 WARNING:  cannot set job '25.svr3.com' attr
> 'Resource_List:neednodes' to 'svr1.com' (rc: 15003 'Cannot set
> attribute, read only or insufficient permission
> Resource_List.neednodes')
> 
> Then, in the maui view of the queue it's "deferred". 
> 
> I didn't find any hint for error 15003 so I'm asking if anybody has any
> idea about it. If it's a PBS related issue, what can be wrong? 

Is maui running as a manager?  ie, if maui is running as user "maui", then
"maui at localhost" or "maui@<fqdn>" will have to a server manager in qmgr.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/mauiusers/attachments/20071120/c10bcc44/attachment.bin


More information about the mauiusers mailing list