[Mauiusers] compile problem

Josh Butikofer josh at clusterresources.com
Tue Jan 16 13:32:59 MST 2007


Mike,

This error means that Maui can't find the TORQUE library libnet.a. These are installed by default in
the /usr/local/lib/ directory. Note that if you are using a fairly new version of TORQUE, libnet.a
is actually part of an all encompassing TORQUE lib named libtorque.so. This lib file is found by
Maui by running the pbs-config executable which is, by default, installed by TORQUE in the
/usr/local/bin directory. Is it possible that TORQUE is installed in a non-default location on your
machine? During the "configure" step are you specifying the correct location for TORQUE? What
version of TORQUE are you trying to use Maui with?

-- 
Joshua Butikofer
Cluster Resources, Inc.

josh at clusterresources.com
Voice: (801) 717-3707
Fax:   (801) 717-3738
--------------------------


Rangitsch, Michael (MJ) wrote:
> Hi all,
>   I'm trying to compile maui (3.2.6) and get a loader error (-lnet not found) when it is compiling in the server directory.  I'm just using the defaults for everything.  Any ideas what could be wrong?  My machine passes all the configuration tests.
> 
> 
> Thanks
> 
> Mike
> _______________________________________________
> mauiusers mailing list
> mauiusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/mauiusers


More information about the mauiusers mailing list