[Mauiusers] Re: error compiling maui-3.2.6p16 with torque-2.1.[0-2]

Meghana Kshirsagar meghana.ksagar at gmail.com
Fri Jan 5 06:44:27 MST 2007


Hello.

I encountered the same problem too..

>> configure: error: can't find pbs-config or libpbs.a

Trying to install the latest maui patches didn't work, nor did creating a
symlink to libtorque.a. I instead created a symlink to 'pbs_config' itself in
the torque installation directory. And then "configure" worked fine.

However, the integration of TORQUE with MAUI doesn't seem to have gone well.
Since, upon restarting the servers (pbs_server, maui), and using the command
"showq" no jobs are listed. Whereas listing jobs with "qstat" shows all
submitted jobs in the queue.

[root at sigma maui]# qstat
Job id              Name             User            Time Use S Queue
------------------- ---------------- --------------- -------- - -----
0.sigma             script.sh        wolf                   0 Q batch
1.sigma             script.sh        wolf                   0 Q batch


One more thing, 'qmgr' lists the pbs_version of my TORQUE installation correctly.

[root at sigma torque_spool]# qmgr -c 'p s'
#
# Create and define queue batch
#
create queue batch
set queue batch queue_type = Execution
set queue batch enabled = True
set queue batch started = True
#
# Set server attributes.
#
set server scheduling = True
set server managers = root at sigma.me.iitb.ac.in
set server operators = root at sigma.me.iitb.ac.in
set server default_queue = batch
set server log_events = 511
set server mail_from = adm
set server resources_default.nodect = 1
set server resources_default.nodes = 1
set server resources_default.walltime = 00:05:00
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
set server pbs_version = 2.1.6

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ I hadn't specified this anywhere.. but it
seems to have detected it correctly.


PLEASE HELP !

- Meghana Kshirsagar,
Sysad, Mech Engg Dept, IIT Bombay.

Rouben Tchakhmakhtchian <rouben <at> utsc.utoronto.ca> writes:

> 
> When I was building MAUI, my solution was to symlink libtorque.a to 
> libpbs.a to go around the problem.
> 
> I think the proper way to do this is to add the location of pbs-config 
> to your PATH. Please correct me if I'm wrong on this one.
> 
> Rouben Tchakhmakhtchian
> High Performance Computing System Administrator
> Information & Instructional Technology Services
> University of Toronto at Scarborough
> -----------------------------------------------
> E-mail: rouben <at> utsc.utoronto.ca
> Phone: 416-208-4732
> Fax: 416-287-7507
> 
> Sebastian Walter wrote:
> > Hi list,
> > 
> > I try to install maui ontop of our working torque installation, but the
> > configure command fails claiming that it can't find the pbs library.
> > Actually, I don't really know whether as the parameter --with-pbs I
> > should use the torque-home-directory (--with-server-home from torque
> > configuration) or the location of the torque source files. The latter
> > works (after chmodding pbs-config executable), but results in a
> > non-working maui installation (not finding torque's nodes/ressources).
> > 
> > If I use the torque-home-dir as I understood by the installation docs,
> > then configure is failing with:
> > configure: error: can't find pbs-config or libpbs.a
> > Of course, there is no libpbs, but a libtorque in torque's `server-home`...
> > 
> > Thanks,
> > Sebastian
> > 
> > _______________________________________________
> > mauiusers mailing list
> > mauiusers <at> supercluster.org
> > http://www.supercluster.org/mailman/listinfo/mauiusers
> 






More information about the mauiusers mailing list