[Mauiusers] Problems with maui make

Josh Butikofer josh at clusterresources.com
Wed May 24 21:10:36 MDT 2006


Jose,

What version of TORQUE are you trying to build against? If you are using TORQUE 2.1.0p0 or higher it 
has a new build system which places all the TORQUE libraries in one file, libtorque.so, instead of 
the separate libnet.a and libpbs.a that Maui patch 14 is looking for. The latest Maui 3.2.6 patch 16 
should now support both the old and new versions of TORQUE's libraries. I would recommend 
downloading it and trying again.

-- 
Joshua Butikofer
Cluster Resources, Inc.

josh at clusterresources.com
Voice: (801) 717-3707
Fax:   (801) 717-3738
--------------------------


josesaez wrote:
> Hi everyone!
> 
> I have compiled and installed correctly torque on an athlon64 machine
> with:  ./configure CC="gcc -m64" --prefix=/usr/local/torque; make; make
> install.  But, when I compile maui with:  ./configure
> --with-pbs=/usr/local/torque; (I edit Makefile to put -D__M64 in OSCCFLAGS,
> as indicates README), and when I execute make, I receive this error:
> (sorry, but my FC4_x86-64 is in spanish)
> 
> gcc -I../../include/ -I/usr/local/maui/include    -D__LINUX     
>  -D__M32COMPAT -g -D__M64  -c MS3I.c
> MS3I.c: En la función ‘MS3LoadModule’:
> MS3I.c:559: aviso: asignación desde un tipo de puntero incompatible
> MS3I.c:560: aviso: asignación desde un tipo de puntero incompatible
> MS3I.c:566: aviso: asignación desde un tipo de puntero incompatible
> MS3I.c:574: aviso: asignación desde un tipo de puntero incompatible
> MS3I.c:579: aviso: asignación desde un tipo de puntero incompatible
> gcc -I../../include/ -I/usr/local/maui/include    -D__LINUX     
>  -D__M32COMPAT -g -D__M64  -c MConst.c
> ar rcs ../../lib/libmcom.a MSU.o MSec.o MXML.o MS3I.o MConst.o
> make[1]: Leaving directory `/root/maui-3.2.6p14/src/mcom'
> make -C src/server all
> make[1]: Entering directory `/root/maui-3.2.6p14/src/server'
> gcc -I../../include -I../../include   -I/usr/local/torque/include    -DLINUX
> -D__MPBS       -g -D__M64  -c Server.c
> gcc -I../../include -I../../include   -I/usr/local/torque/include    -DLINUX
> -D__MPBS       -g -D__M64  -c UserI.c
> gcc -I../../include -I../../include   -I/usr/local/torque/include    -DLINUX
> -D__MPBS       -g -D__M64  -c SDR.c
> gcc -I../../include -I../../include   -I/usr/local/torque/include    -DLINUX
> -D__MPBS       -g -D__M64  -c LLI.c
> gcc Server.o UserI.o SDR.o LLI.o -o ../../bin/maui -L../../lib
> -L/usr/local/torque/lib   -lmoab -lmcom     -lnet -lpbs   -lm
> /usr/bin/ld: no se puede encontrar -lnet
> collect2: ld devolvió el estado de salida 1
> make[1]: *** [maui] Error 1
> make[1]: Leaving directory `/root/maui-3.2.6p14/src/server'
> make: *** [all] Error 2
> 
> 
> # "aviso: asignación desde un tipo de puntero incompatible" means "warning:
> asign from an incompatible type of pointer"
> 
> # "/usr/bin/ld: no se puede encontrar -lnet" means "/usr/bin/ld:  cannot find
> -lnet"
> 
> # "collect2::  ld devolvió el estado de salida 1" means "collect2: ld
>  returned output state 1"
> 
> 
> 
> Torque libraries are under /usr/src/torque/lib; so, as I indicate in the
> previuos compilation sequence, maui must easily find them.  I have tried
> several configurations, but none seems to work.  Any help would be
> appreciated.
> 
> Thanks in advance.
> 
> Jose Sáez
> _______________________________________________
> mauiusers mailing list
> mauiusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/mauiusers


More information about the mauiusers mailing list