[Mauiusers] Re: problem with pbs

luxun luxun6 at gmail.com
Thu Mar 30 17:32:22 MST 2006


Thanks for your help.
My pbs configuration as following:

#
# Create queues and set their attributes.
#
#
# Create and define queue batch
#
create queue batch
set queue batch queue_type = Route
set queue batch route_destinations = serial
set queue batch route_destinations += parallel
set queue batch enabled = True
set queue batch started = True
#
# Create and define queue serial
#
create queue serial
set queue serial queue_type = Execution
set queue serial resources_max.nodect = 1
set queue serial resources_default.nodect = 1
set queue serial resources_default.nodes = 1:ppn=1
set queue serial enabled = True
set queue serial started = True
#
# Create and define queue parallel
#
create queue parallel
set queue parallel queue_type = Execution
set queue parallel resources_max.nodect = 64
set queue parallel resources_min.nodect = 2
set queue parallel resources_default.nodect = 2
set queue parallel resources_default.nodes = 2:ppn=1
set queue parallel enabled = True
set queue parallel started = True
#
# Set server attributes.
#
set server scheduling = True
set server acl_host_enable = False
set server acl_user_enable = False
set server default_queue = batch
set server log_events = 511
set server mail_from = adm
set server query_other_jobs = True
set server resources_default.neednodes = 1
set server resources_default.nodes = 1:ppn=1
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
set server default_node = 1
set server pbs_version = 2.0.0p8-1cri


2006/3/31, Marek Muzyk <muzyk at icm.edu.pl>:
>
> Hello,
> I am not a pbs expert, but if you send me result of command
> qmgr -c "print server"
>
> I'm writing  more (I hope).
>
> Mark
>
>
> Dear all,
>
> I am running maui-3.2.6p14 and torque-2.0.0p8 on RHEL 4 WS.
> I define 3 queues, batch, serial, parallel.
> batch is a routing queue, serial is for single node and parallel is for
> multiple nodes.
> host i151.ascc, i152.ascc, i153.ascc, i154.ascc are for serial queue.
> host i155.ascc, i156.ascc are for parallel queue.
>
> When I submit a parallel job, I wish the job running on parallel queue.
> But the parallel job running on serial queue.
> My serial job also running on parallel queue.
> Maybe the partition define in maui is not work.
>
> Have any idea? Thanks.
>
> I have checke partition status as following:
> Displaying Partition Status
>
> System Partition Settings:  PList: DEFAULT:SERIAL:PARALLEL PDef: DEFAULT
>
> Name                    Procs
>
> ALL                         6
> DEFAULT                     0
> SERIAL                      4
> PARALLEL                    2
>
> Partition    Configured         Up     U/C  Dedicated     D/U     Active
> A/U
>
>
> NODE----------------------------------------------------------------------------
> ALL                   6          6 100.00%          0   0.00%          0
> 0.00%
> SERIAL                4          4 100.00%          0   0.00%          0
> 0.00%
> PARALLEL              3          2 100.00%          0   0.00%          0
> 0.00%
> .....
> Class/Queue State
>
>               [<CLASS> <AVAIL>:<UP>]...
>
>           ALL [batch 6:6][serial 6:6][parallel 6:6]
>        SERIAL [batch 4:4][serial 4:4][parallel 4:4]
>      PARALLEL [batch 2:2][serial 2:2][parallel 2:2]
>
>
> There are some message in maui.log:
> 03/30 15:43:28 __MPBSGetNodeState(Name,State,PNode)
> 03/30 15:43:28 INFO:     PBS node i154.ascc set to state Idle (free)
> 03/30 15:43:28 MPBSNodeUpdate(i154.ascc,i154.ascc,Idle,base)
> 03/30 15:43:28 MPBSLoadQueueInfo(base,i154.ascc,SC)
> 03/30 15:43:28 INFO:     queue 'batch' started state set to True
> 03/30 15:43:28 INFO:     class to node not mapping enabled for queue
> 'batch' adding class to all nodes
> 03/30 15:43:28 INFO:     queue 'serial' started state set to True
> 03/30 15:43:28 INFO:     class to node not mapping enabled for queue
> 'serial' adding class to all nodes
> 03/30 15:43:28 INFO:     queue 'parallel' started state set to True
> 03/30 15:43:28 INFO:     class to node not mapping enabled for queue
> 'parallel' adding class to all nodes
>
> My maui.cfg as following:
> SERVERHOST            i159.ascc
> ADMIN1                root
> RMCFG[base] TYPE=PBS
> RMPOLLINTERVAL        00:00:30
>
> SERVERPORT            42559
> SERVERMODE            NORMAL
> LOGFILE               maui.log
> LOGFILEMAXSIZE        10000000
> LOGLEVEL              3
> QUEUETIMEWEIGHT       1
> BACKFILLPOLICY        FIRSTFIT
> RESERVATIONPOLICY     CURRENTHIGHEST
> NODEALLOCATIONPOLICY  CPULOAD
> DEFERTIME             0
>
> SRPARTITION[serial]  SERIAL
> SRTASKCOUNT[serial]  4
> SRRESOURCES[serial]  PROCS=-1
> SRCLASSLIST[serial]  serial
> SRPERIOD[serial]     INFINITY
>
> SRPARTITION[parallel]  PARALLEL
> SRTASKCOUNT[parallel]  3
> SRRESOURCES[parallel]  PROCS=-1
> SRCLASSLIST[parallel]  parallel
> SRPERIOD[parallel]     INFINITY
>
> NODECFG[i151.ascc] PARTITION=SERIAL
> NODECFG[i152.ascc] PARTITION=SERIAL
> NODECFG[i153.ascc] PARTITION=SERIAL
> NODECFG[i154.ascc] PARTITION=SERIAL
> NODECFG[i155.ascc] PARTITION=PARALLEL
> NODECFG[i156.ascc] PARTITION=PARALLEL
>
>
>
>
>
> --------------------------------------------------------------------------------
>
>
> _______________________________________________
> mauiusers mailing list
> mauiusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/mauiusers
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/mauiusers/attachments/20060331/16b70719/attachment.html


More information about the mauiusers mailing list