[Mauiusers] Maui really support SGE?

Wightman wightman at clusterresources.com
Wed Feb 1 08:33:26 MST 2006


Maui did support SGE 5.3 at one time.  However, the routines needed by
Maui inside of SGE changed (they are removed in 6.0).  Because of this
there is no longer support for SGE.

- Douglas

On Wed, 2006-02-01 at 18:41 +0900, OHKUBO Katsuhiko wrote:
> Hello.
> 
> I want to run Maui with current Sun Grid Engine (SGE).
> So, I configured by
>   % ./configure --with-sge=/some/where/gridengine/source
> 
> maui-3.2.6p14/Makefile was made with
> 	# SGE Definitions
> 	export SGEDEF=-D__MSGE -D__SGE_NO_USERMAPPING__
> 	export SGETOP  = /some/where/gridengine/source
> 	...
> 
> But "DEFS =" in  src/moab/Makefile doesn't have $(SGEDEF), 
> MRM.c (which has #ifdef __MSGE) is compiled *without* -D__MSGE.
> 
> So I added $(SGEDEF) at last of DEFS in src/moab/Makefile and run make.
> But it ended with
>   ../../lib/libmoab.a(MRM.o)(.text+0x61): In function `MRMLoadModules':
>   .../maui-3.2.6p14/src/moab/MRM.c:180: undefined reference to `MSGELoadModule'
> 
> I cannot find MSGELoadModule() in all of source in maui-3.2.6p14.
> I think src/moab/MPBSI.c is for PBS, MWikiI.c for Wiki,
> but where is MSGEI.c for SGE?
> 
> 
> Is Maui really support SGE now??
> 
> -----------
> Katsuhiko OHKUBO ohkubo-k at suri.co.jp
> 
> _______________________________________________
> mauiusers mailing list
> mauiusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/mauiusers



More information about the mauiusers mailing list