[Mauiusers] Maui not scheduling valid jobs when nodes are available

Prakash Velayutham prakash.velayutham at cchmc.org
Thu Dec 14 14:09:09 MST 2006


Josh Butikofer wrote:
> Prakash,
>
> It is not clear to me from this log file why the job's reservation cannot be made. Do you have any
> existing reservations on the system? (Use showres to see.) Also, can you increase the loglevel to
> see if the logs give more details? (Increase your LOGLEVEL setting to 6 or 7, restart Maui, and try
> the test case again.)
>
> Regards,
Hi Josh,

Thanks for the reply. Actually, I figured out why Maui was not
scheduling. Here is the reason.

Here is my initial system's qmgr:

#####################################################################
create queue users
set queue users queue_type = Execution
set queue users acl_host_enable = True
set queue users acl_hosts = ***
set queue users acl_hosts += ***
set queue users resources_min.cput = 00:00:01
set queue users resources_default.neednodes = 1:xeon
set queue users resources_default.nodect = 1
set queue users resources_default.nodes = 1:xeon

set server scheduling = True
set server acl_host_enable = True
set server acl_hosts = ***
set server acl_hosts += ***
set server managers = root@***
set server operators = root@***
set server log_events = 511
set server mail_from = adm
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
set server pbs_version = 2.1.6
#####################################################################

Once I changed the resources lines in the queue configuration to
set queue users resources_default.neednodes = 1
set queue users resources_default.nodect = 1
set queue users resources_default.nodes = 1

Maui started scheduling fine. With the previous qmgr, Torque scheduler
was working just fine. I do not understand why Maui would stop working.

I have another question here though.

Each of my nodes have 2 CPUs and 8 GB RAM. I have a total of 12 nodes. I
have a particular software which will only work in 6 of these nodes and
when a user requests that software, he should be given both the CPUs in
the node regardless as the software takes up a lot of RAM (almost 6 - 7
GB). How can I make this condition work? I know a little bit about GRES
in Maui, but do not really know more than that. I also tried to work
with the Torque MOM config file to enable the generic resources, but
some pointers would help.

Thanks,
Prakash


More information about the mauiusers mailing list