[Mauiusers] MAXNODES broken?

Michael Shuey shuey at purdue.edu
Thu Oct 28 10:32:28 MDT 2004


Does the MAXNODES limit actually work in recent versions of Maui?  I've
tried 3.2.6p9, p10, and p11-snap.1090086588, but none behave as
expected.  I've added this to my maui.cfg:

CLASSCFG[testq]     MAXNODE=2 MAXJOB=100 MAXPROC=10

When I run diagnose -c testq (after submitting a single job), I see:

Class/Queue Status

Name           Priority Flags        QDef              QOSList*
PartitionList     Target Limits

testq                 0 [NONE]       [NONE]             [NONE] 
[NONE]      0.00  MAXJOB=1:100 MAXNODE=0:2 MAXPROC=1:10

So, it looks like maui notices that a job is running, and it realizes
that it's a single-proc job, but it doesn't increment the number of
nodes in use.  Further poking proves I can submit, and maui will
schedule, jobs that use more than 2 nodes (as long as they don't exceed
the 10-processor limit).

Is this a bug, or am I missing something?

-- 
Michael Shuey <shuey at purdue.edu>
Purdue University/ITaP


More information about the mauiusers mailing list