[gold-users] gold cli error

akshar bhosale akshar.bhosale at gmail.com
Wed Feb 26 19:01:50 MST 2014


Hi,

we are using gold (2.1.7.1)with maui 2.3.6p1 and pbs 2.5.8.

when we run any gold  command using cli, we are getting below error


./glsuser -u john
Failed sending message: (Unable to connect to socket (Protocol not
available)).

whereas from gold gui, all the things are working fine.

gold log says :

#################################################################
2014-02-27 07:14:39 ERROR Gold::Exception::new  Unable to connect to socket
(Protocol not available) at /opt/gold/lib/Gold/Message.pm line 214.
2014-02-27 07:14:39 ERROR Gold::Chunk::__ANON__  Failed sending message:
(Unable to connect to socket (Protocol not available)).
2014-02-27 07:14:39 INFO  main::  ./glsuser (PID 17848) Exiting with status
code (222)
2014-02-27 07:22:48 INFO  Gold::BEGIN  ./glsuser (PID 26995) Started
*******************************************
##################################################################
these are procs running

postgres 22136     1  0 Feb26 ?        00:00:00 /usr/bin/postmaster -p 5432
-D /var/lib/pgsql/data
postgres 22138 22136  0 Feb26 ?        00:00:00 postgres: logger
process
postgres 22156 22136  0 Feb26 ?        00:00:00 postgres: writer
process


gold     22230     1  0 Feb26 ?        00:00:00 /usr/bin/perl -wT
/opt/gold/sbin/goldd

postgres 22136     1  0 Feb26 ?        00:00:00 /usr/bin/postmaster -p 5432
-D /var/lib/pgsql/data

pgsql log do not say anything.

any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/gold-users/attachments/20140227/6f863296/attachment.html 


More information about the gold-users mailing list