[gold-users] Bug: configure.ac patch

Jonas Juselius jonas.juselius at uit.no
Tue Oct 9 00:52:36 MDT 2012


It's a very common thing to do when building e.g. rpm or deb packages.

Jonas

On 10/08/2012 09:40 PM, Michael Sternberg wrote:
> Hi,
> 
> Isn't that an unusual way of doing things? I never had a problem (on EL5) starting off ./configure and doing this:
> 
>     # http://www.adaptivecomputing.com/resources/docs/gold/x364.php
>     ./configure --prefix=/opt/soft/gold-2.2.0.5-1  … 
> 
>     make
>     make gui
>     make deps
>     make install install-gui
> 
> 
> Michael
> 
> 
> On 2012-10-08, at 14:16 , Scott Jackson <scottmo at adaptivecomputing.com> wrote:
> 
>> Hi Jonas,
>>
>> Thanks for the patch. In looking at this, to me it appears that this will cure the problem in the install process, but I believe it will break the LOG_DIR substitutions in the goldsh histfile and  the Log.Filename in each of the configuration files, since these will not know how to resolve "${prefix}". I will need to resolve these issues before applying the patch.
>>
>> Thanks,
>>
>> Scott
>>
>>
>> On Mon, Oct 8, 2012 at 9:22 AM, Jonas Juselius <jonas.juselius at uit.no> wrote:
>> There is a minor bug in the configure.ac file which causes
>>
>> $ make prefix=/somewhere/else install
>>
>> to fail. The problem is that ${prefix} gets expanded too early. I have
>> included a patch which fixes the bug:
>>
>> $ patch -p1 < prefix.patch
>>
>> Regards, Jonas
> 
> _______________________________________________
> gold-users mailing list
> gold-users at supercluster.org
> http://www.supercluster.org/mailman/listinfo/gold-users
> 

-- 
Dr. Jonas Juselius <jonas.juselius at uit.no>
High Performance Computing Group, University of Tromsø
Tel. +47 776 60400 Mobile. +47 47419869


More information about the gold-users mailing list