[gold-users] Gold no longer working

Shade Alabsa shade34321 at gmail.com
Fri Jul 27 15:16:36 MDT 2012


I looked into what you said and it looks like GOLD_HOME is unset among a
few other things. Part of the reason we updated everything was because we
had last /etc, long story, so of course we don't have a /etc/gold.cfg. As
of right now I think I'm going to update it as well and go from there.
Thanks for the help!

Shade

On Thu, Jul 26, 2012 at 7:21 PM, Scott Jackson <
scottmo at adaptivecomputing.com> wrote:

> What is your path to glsuser?
>
> `which glsuser`
>
> Is it /usr/local/gold/bin/glsuser or might there be another installation
> that got partially installed?
>
> Also, do you have GOLD_HOME in your environment.
>
> `env | grep GOLD_HOME`
>
> Perhaps this has been set or unset from what it was before.
>
> Is there an /etc/gold.cfg?
>
> What is the use lib path at the top of your glsuser file?
>
> `grep 'use lib' `which glsuser``
>
> use lib qw(/opt/gold-upgrade/lib /opt/gold-upgrade/lib/perl5);
>
> This will tell you where the Gold.pm is that it is using.
>
> From the Gold.pm, it builds the location ($PREFIX)  for the auth_key file.
>
>
>    # Set $PREFIX from Environment variable, Cfg File, or Hard-coded default
>
>     if ($ENV{GOLD_HOME}) { $PREFIX = $ENV{GOLD_HOME}; }
>     elsif (-e "/etc/gold.cfg")
>     {
>         my ($var, $val);
>         open(ENV, "/etc/gold.cfg");
>         while (<ENV>)
>         {
>             chomp;       # Remove trailing whitespace
>             s/^\s+//;    # Remove leading whitespace
>             s/\#.*//;    # Strip off comments
>             next unless ($var, $val) = split("[= ]+", $_, 2);
>             $ENV{$var} = $val;
>         }
>         $PREFIX = $ENV{GOLD_HOME};
>     }
>     else { $PREFIX = "/opt/gold"; }
>
>    open AUTH_KEY, "${PREFIX}/etc/auth_key"
>
>
>
> On Thu, Jul 26, 2012 at 4:07 PM, Shade Alabsa <shade34321 at gmail.com>wrote:
>
>> Ideally I'd like to upgrade Gold but at the time we were only doing what
>> was necessary to get our cluster back up and running.
>>
>> Gold was installed to /usr/local/ so I checked there and there still is a
>> auth_key file,
>>
>> [root at mgt maui]# locate auth_key
>> /usr/local/gold/etc/auth_key
>> /usr/local/gold-2.1.6.0/etc/auth_key
>> /usr/local/src/gold-2.1.11.0/etc/auth_key
>>
>> I'm assuming gold-2.1.11.0 is the old installation. I'm not sure what you
>> mean by resync it with CSKEY value in maui-private.cfg, mainly becasue my
>> maui-private.cfg file has nothing in it. Thanks for the speedy response and
>> sorry for the long delay.
>>
>> Shade
>>
>> On Thu, Jul 26, 2012 at 2:07 PM, Scott Jackson <
>> scottmo at adaptivecomputing.com> wrote:
>>
>>> So, you didn't upgrade Gold?
>>>
>>> It appears you may have deleted/moved the /opt/gold/etc/auth_key file.
>>> You should be able to regenerate it by running make auth_key as root from
>>> your original gold tarball unpack directory. You will have to use the same
>>> key as before or else resync it with the CSKEY value in maui-private.cfg.
>>>
>>> I hope this helps.
>>>
>>> Scott
>>>
>>>
>>> On Thu, Jul 26, 2012 at 11:46 AM, Shade Alabsa <shade34321 at gmail.com>wrote:
>>>
>>>> We are currently using the Gold accounting manager, version 2.1.6.0.
>>>> Recently we had to upgrade our xcat, torque, and maui installations and now
>>>> Gold is not working anymore. I get the following errors:
>>>>
>>>> [root at mgt ~]# glsuser
>>>> Unable to open auth_key file: No such file or directoryBEGIN
>>>> failed--compilation aborted at /usr/local//lib/Gold.pm line 150.
>>>> Compilation failed in require at /usr/local/bin/glsuser line 57.
>>>> BEGIN failed--compilation aborted at /usr/local/bin/glsuser line 57.
>>>> [root at mgt ~]# gusage -s 2012-07-01 -e 2012-07-31 -p CCL >>
>>>> garuda-summary-July_12.log
>>>> Unable to open auth_key file: No such file or directoryBEGIN
>>>> failed--compilation aborted at /usr/local//lib/Gold.pm line 150.
>>>> Compilation failed in require at /usr/local/bin/gusage line 53.
>>>> BEGIN failed--compilation aborted at /usr/local/bin/gusage line 53.
>>>>
>>>> I'm not quite sure what the problem is or if our upgrades broke it. Any
>>>> help you can provide would be great! Thanks!
>>>>
>>>> Shade
>>>>
>>>> _______________________________________________
>>>> gold-users mailing list
>>>> gold-users at supercluster.org
>>>> http://www.supercluster.org/mailman/listinfo/gold-users
>>>>
>>>>
>>>
>>> _______________________________________________
>>> gold-users mailing list
>>> gold-users at supercluster.org
>>> http://www.supercluster.org/mailman/listinfo/gold-users
>>>
>>>
>>
>> _______________________________________________
>> gold-users mailing list
>> gold-users at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/gold-users
>>
>>
>
> _______________________________________________
> gold-users mailing list
> gold-users at supercluster.org
> http://www.supercluster.org/mailman/listinfo/gold-users
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/gold-users/attachments/20120727/cddcfe82/attachment-0001.html 


More information about the gold-users mailing list