[gold-users] web interface list only?

Brian O'Connor oconnorb at unimelb.edu.au
Mon May 3 19:58:03 MDT 2010

Thanks Scott,

I just restarted everything again and this time it all worked!

The gui looks fine.

Thanks for your pointers

-----Original Message-----
From: Scott Jackson [mailto:scottmo at adaptivecomputing.com]
Sent: Tue 5/4/2010 7:19 AM
To: Brian O'Connor
Cc: gold-users at supercluster.org
Subject: Re: [gold-users] web interface list only?

Yes. The gui should allow properly authorized users to create and modify objects, etc.

Now, you say you logged in as root. I assume you were able to do this after doing a gchpasswd root command on the prompt. Does root have superuser privileges within Gold from the command line (I.e. can you create/change projects as root from the command line?). [You can see what I am driving at ... does it help if you login as the gold power user [gold]?]

I assume you have tried these things and there is some other problem that I have not seen before.

Make sure the user you are logging in as is listed as one of the users from `goldsh RoleUser Query Role==SystemAdmin`
If not, then use the goldsh interface to add them as a SystemAdmin `goldsh RoleUser Create Role=SystemAdmin Name=root`
Make sure they have a gui passwd with gchpasswd root.
Then login, and see if it looks better.

If not, please send me the results of: `goldsh Role Query`, `goldsh RoleUser Query`, `goldsh RoleAction Query`.
Then reproduce the problem in the gui and examine the goldg.log and goldd.log for additional details. If you cannot discover the problem after examining the logs for a bit, then send me an email with the logs attached.



----- Original Message -----
From: "Brian O'Connor" <oconnorb at unimelb.edu.au>
To: gold-users at supercluster.org
Sent: Monday, May 3, 2010 2:06:47 AM
Subject: [gold-users] web interface list only?

web interface list only?

We are trying GOLD ( with mysql (5.0.51a-24+lenny3) apache2

After following the instructions everything seems to work fine from the
command line
but the web gui only allows us to *list* users or projects etc, not
create or modify them.
even if I log in as root.

Is the gui supposed to be able to allow a properly authorized user to
create and modify
users etc, or is this a read only gui?

Is this a broken install or is there something else I'm missing?
_______________________________________________ gold-users mailing list
gold-users at supercluster.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/gold-users/attachments/20100504/73c12fb1/attachment.html 

More information about the gold-users mailing list